Back to overview
Downtime

Shared Hosting (cPanel) - Mumbai, India and cPanel Reseller Hosting Server (India) are down

Nov 25 at 11:14am IST

Resolved
Nov 26 at 05:48am IST

Shared Hosting (cPanel) - Mumbai, India and cPanel Reseller Hosting Server (India) recovered.

Created
Nov 25 at 11:14am IST

Shared Hosting (cPanel) - Mumbai, India and cPanel Reseller Hosting Server (India) went down.