Back to overview
Downtime

Shared Hosting (cPanel) - Mumbai, India and cPanel Reseller Hosting Server (India) are down

Nov 6, 2025 at 5:28am UTC

Resolved
Nov 6, 2025 at 6:16am UTC

Shared Hosting (cPanel) - Mumbai, India and cPanel Reseller Hosting Server (India) recovered.

Updated
Nov 6, 2025 at 5:34am UTC

Shared Hosting (cPanel) - Mumbai, India and cPanel Reseller Hosting Server (India) went down.

Updated
Nov 6, 2025 at 5:28am UTC

Shared Hosting (cPanel) - Mumbai, India and cPanel Reseller Hosting Server (India) recovered.

Created
Nov 6, 2025 at 5:28am UTC

Shared Hosting (cPanel) - Mumbai, India and cPanel Reseller Hosting Server (India) went down.