Back to overview
Downtime

Shared Hosting (cPanel) - Mumbai, India and cPanel Reseller Hosting Server (India) are down

Sep 27, 2025 at 6:59am UTC

Resolved
Sep 27, 2025 at 7:11pm UTC

Shared Hosting (cPanel) - Mumbai, India and cPanel Reseller Hosting Server (India) recovered.

Updated
Sep 27, 2025 at 7:08pm UTC

Shared Hosting (cPanel) - Mumbai, India and cPanel Reseller Hosting Server (India) went down.

Updated
Sep 27, 2025 at 6:51pm UTC

Shared Hosting (cPanel) - Mumbai, India and cPanel Reseller Hosting Server (India) recovered.

Updated
Sep 27, 2025 at 6:50pm UTC

Shared Hosting (cPanel) - Mumbai, India and cPanel Reseller Hosting Server (India) went down.

Updated
Sep 27, 2025 at 4:50pm UTC

Shared Hosting (cPanel) - Mumbai, India and cPanel Reseller Hosting Server (India) recovered.

Updated
Sep 27, 2025 at 4:47pm UTC

Shared Hosting (cPanel) - Mumbai, India and cPanel Reseller Hosting Server (India) went down.

Updated
Sep 27, 2025 at 10:20am UTC

Shared Hosting (cPanel) - Mumbai, India and cPanel Reseller Hosting Server (India) recovered.

Updated
Sep 27, 2025 at 10:20am UTC

Shared Hosting (cPanel) - Mumbai, India and cPanel Reseller Hosting Server (India) went down.

Updated
Sep 27, 2025 at 7:02am UTC

Shared Hosting (cPanel) - Mumbai, India and cPanel Reseller Hosting Server (India) recovered.

Created
Sep 27, 2025 at 6:59am UTC

Shared Hosting (cPanel) - Mumbai, India and cPanel Reseller Hosting Server (India) went down.